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Overview

This test plan covers how to log into an Orion account as a specific GVT Tester and how to walk through the Orion User Interface and Pages checking for GVT issues.

Orion is essentially an Integrated Development Environment (IDE) with the exception that instead of downloading it and running it on your desktop, all you need is a
modern browser (Orion will warn you if your browser is out of date) and a login to the Orion web site you want to test.

Orion is made up of different pages that accomplish common tasks developers need to write code. This test plan will cover the different pages and how to navigate around
them. It is important to note that there is a flow to this test plan that should result in the tester leaving the &€ceworkspacea€ (or the files in the server accessed by Orion) in
the same state as when they started. Everything that is added to the testers workspace is eventually deleted in the set of tests and then the tester logs out.

Since Orion is a web app, there are a few terms that should be covered. The first thing is the selection policy in Orion. Orion does support context sensitive menus in the

navigator however often you have to select a row in the UL To do this click in the row but not over any content. Clicking on a a€cefilenamea€ in a list of files does not
necessarily select it, it might open it up in the editor. So to 4€ceselecta€ that file, click to the right but in the same horizontal space as the filename
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Logging In

Use gvttesterl, gvttester2, gvttester3 as user names to login to http://tvt80.orion.eclipse.org:9000/.

All tests are prefixed with a GVT#### for referencing in bug reports if necessary

Part 1 Editor

GVTO0100 After logging in you will be put into the Editor Page. Check the following page


http://tvt80.orion.eclipse.org:9000/

€« = C https://orion.eclipse.org/edit/edit.html
i Apps B Orion B Open Source Sit... B WebDevHelp B Context Menu B/ [BM B JazzHub B BlueMix

Orion Content
File  Edit View
Orion Content {orion.eclipse.org) -

» Testing ¥ Projects

Testing

w Orion Content

3 Testing 2014 2:23:07 PM

GVTO0110 Create a new Basic Project using the File menu.

1) Click on File->New->Project->Basic. Enter a project name of your choice in the prompt that appears.

File | Edit View

I e o Fouder Create an empty project
- ] ]
Link to Server

» Testing I Project N I Basic w Projects
File System Testing
SFTP
Git Repository

w Orion Content

2) Verity that the Project you created has the name you selected.



Orion Content / BasicProject

File Edit View Deploy Deploy As

BasicProject

projectjson w Project Information

Name

Description

Site

w BasicProject

projectjson 4/9/2014 11:33:03 AN

GVT0120 Modify the Project Name, Description, and Site.

1) Move your mouse over the project &€ceNamea€ in the a4€ceProject Informationa€ section on the right-hand side and click on it. Modify the name.
2) Move your mouse over the empty project 4€ceDescriptiona€ area and click on it. Input a project description of your choice.

3) Move your mouse over the empty project a€ceSitea€ area and click on it. Input a website address of your choice.

w» BasicProject

projectjson w Project Information

Hate RenamedBasicProject
Description This is a GVT test project
Site

http: [ fwww.google.com)|

Click to ed

w BasicProject

projectjson 4/9/2014 11:33:03 AM

4) Click outside of the a€ceSitea€ input box. This will save the newly entered Site.
5) Refresh the page. Verify that the information you entered was saved correctly and that the project name in the navigator on the left hand side matches the new project

name you entered in the Project Information section. Note that the breadcrumb (highlighted below) will still have the original project name you selected when you created
the project. At the time this document was written this is the expected behavior.

= Breadcrumb E>E’ion Content.-'BasicProjeﬂ

File Edit View Deploy Deploy As

w|RenamedBasicProject

projectjson

w Project Information

Name RenamedBasicProject
Description This is a GVT test project
Site
http:/ fwww.google.com
w BasicProject
projectjson 4/9/2014 11:42:04 AN

GVT0130 New file/folder creation

1) Create a new file using the File menu. Click on File->New->File



2) Input a file name of your choice and press the Enter key
= Orion Content / BasicProject

File Edit View Deploy Deploy As

w» RenamedBasicProject

_mYNeWFﬂe-Wﬂ ] w Project Information

projectjson

Name RenamedBasicProject

Description This is a GVT test project

3) Verify that a new file with the name you entered was created. An icon should appear next to the file name and it should be automatically opened in the Editor on the
right- hand side. The breadcrumb should indicate the new file name correctly.

= | Orion Content / BasicProject | myNewFile. txt I

File Edit View Deploy Deploy As

w» RenamedBasicProject

B myNewFile bt

projectjson

4) Create a new folder and verify that it was successfully created with the name you selected by repeating steps 1-3 and selecting Folder instead of File from the File-

>New menu in step 1.
| Orion Content / BasicProject | myNewFolder I

, File Edit View Deploy Deploy As

w» RenamedBasicProject

o
myMewFaolder
yNewFolder
Q B myNewFile bt
Use the File menu to create new files and folders. Click a file to start coding.
= projectjson

GVT0140 File/Folder renaming
1) Right click on your newly created file and select &€eRenamea€ from the context menu.

File Edit View Deploy Deploy As

w» RenamedBasicProject

» myMewFolder

B myNewFile.tt Rename the selected files or folders

projectjson I Rename F2
Cut Ctri+X
Copy Ctri+C
Paste Ctri+V
Delete DEL
Open With 3

Open Related 8
Import .

2) Input a new name of your choice, press Enter and verify that the file has been properly renamed.

3) Rename your newly created folder the same way you renamed the file and verify that the folder now has the new name you selected.



Orion Content / BasicProject / renamedlewFolder

File Edit View Deploy Deploy As

w» RenamedBasicProject

renamedhewFolder
w renamedNewFolder

projectjson

Use the File menu to create new files and folders. Click a file to start coding.
renamediewFile. ted

GVTO0150 Find renamed file using 4€eFind Filea€ dialog

1) Ensure that the file you renamed in the previous test is NOT open in the editor. You can do this by opening the project.json file or by clicking on the renamed folder to
open it.

2) Launch the Find File dialog by pressing Ctrl+Shift+F (Cmd+Shift+F MacOS).

3) Start typing the name of the file you renamed in the previous test. You should see a link to the file appear below the text input. Click on it and make sure that the file
has been successfully opened in the editor.

Orion Content / BasicProject / renamedNewFolder

V4
RenamedBasicProject
m
renamedhle
Q [ projectjson
B renamedhewFile bt
=
@

Find File Named

Type the name of a file to apen (? = any character, * = any string):

| renamedhew |

@ renamedNewFile.td J

GVTO0160 Text file input 1) Open the file you renamed in the previous test by clicking on the file name in the navigator on the left-hand side. 2) Start typing content in the
Orion editor in the language of your choice. Press Ctrl+S (Cmd+S Mac- OS), or use the File menu, to save the content.

Orion Content / BasicProject / renamedNewfFile txt

, File Edit View Deploy Deploy As

= v RenamedBasicProject Start typing in the language of your choice.
» renamediewFolder

o} projectjson

= B renamediewFile td



3) Navigate to the renamed folder by clicking on the folder name in the navigator. 4) Open the file you modified in step 2 again and verify that the content was saved

correctly.

GVT0170 Searching and replacing in a file

1) Open the file you created in the previous step.

2) Ensure the file has at least 3 lines of content with repeated words and save it. You can do this by copying the first line and pasting it twice. (Ctrl+C and Ctrl+V
keyboard shortcuts should work, Mac equivalents should work as well, otherwise you can use the Edit menu to copy and paste)

3) Place your cursor at the beginning of the file and press Ctrl+F (Cmd+F MacOS) to open the find/replace dialog.

Pl Fic  Edic  View Deploy  Deploy As typing| e s o Replace
i w RenamedBasicProject Start Eyping in the language of your choice.
¥ renamediewFaolder Start typing in the language of your choice.
Q projectjson start typing in the language of your choice.
m B renamedMewFile bd

4) Type in a search string in the language of your choice that will match text in the editor.

Orion Content |/ BasicProject / renamedNewFile.txt

5) Ensure the text is highlighted properly for the first match (subsequent matches show in lighter color).

6) Press a€ceenter/returna€ to match the next entry. You should be able to keep pressing enter to loop around the matches.

7) Type in a replacement string in the language of your choice in the 4€eReplace Witha€ entry field and press a€eReplacea€.

File  Edit WView Deploy  Deploy As

w renamediewFolder

r 4
w
Q

project json

typing

Orion Content / BasicProject | renamedNewrFile.txt *

Next Previous | othertext

w RenamedBasicProject Start othertext in the language of your choice.

Start Eyping in the language of your choice.

Start typing in the language of your choice.

2 renamedMewFile txt

B

8) The first (or the occurrence you currently had highlighted) should be replaced.

9) Then press Replace All and ensure all selections are replaced.

10) Do NOT press Save, instead simply refresh the page reverting all your changes.

File  Edit  View Deploy  Deploy As

w» renamedNewFolder

project json
2 renamedMewFile txt

(1 £ & »

GVT0180 Incremental find

1) Open the file you modified in the previous test

2) Use the incremental find function Ctrl+J (Cmd+J MacOS)

typin g:

» RenamedBasicProject Start othertext in the 1:i
Start othertext in the 1:

Start othertext in the 13

3) Start typing some text that should match what's in the editor in the language of your choice.

Confirm Reload

There are unsaved changes.

Are you sure you want to reload this page?

Reload this Page Don't Reload

Replace All

Options
e Rep
@ Replace |Rep



QOrion Content / BasicProject / renamedNewFile.txt
Increme

Start typing in the of your choice.
Start typing in the language of your choice.

Start typing in the language of your choice.

Part 2 Repositories

GVTO0200 Clone a repository

1) In the vertical side-menu click on the repositories link

File  Edit View Create new

@ v test1 at github.com

Git Repository

L » hinarvFiles

2) The Repositories page should open. Click on the drop down button and then click on the 4€ceClone Repositorya€ button.

3) In the popup that appears click on the &€ceMorea€ button.

= Git

REPOSITORY: testNIsPlugins(v] REFERENCE: master v

Y

Active Branch Ch

TGO, OO T PO (S

Wi test1 fii
D 11 Oit url: https://github.com/libingw/test1_git
location: root / test1
¥ OUTGOING | testCralwer m us
git url: hitps://hub.jazz .net/git/Scott/Sentiment. Analysis/
No Changes location: root / testCralwer
testNIsPlugins = |
v INCOMING | (g remote]g m fuc
location: root / testNIsPlugins
Mo Changes
testRepoRC2 4|]=]L
v HISTORY | (0o remote) " lpt
Clone Repository | Init Repository -Pt
(in

fro

4) Another dialog window with &€ceClone Git Repositorya€ should open. In this dialog enter a€cegit://github.- com/kenwalker/webapp_example.gita€ as the Repository
URL. Make sure that the 4€ceNew foldera€ radio button is selected and enter a name for the new folder in the language of your choice. Click OK



Clone Git Repository
Repository URL[ git:Mgithub.comikenwalkeriwebapp_example.git I

|'?' Mew folder:  |MyClonedFolder I

' Existing directory: Change...

Default target location

oK

5) This action will 4€ceclonea€ code from a GitHub repository into your Orion Workspace. Essentially, it adds some code you can look at. Click on the repository drop
down button and select the one that you just created.

REPOSITORY: |MyCIonedFoIder vl REFERENCE: master => origin/master v

Filter items 7
Active Branch
eclipse.platform.ui fii -
Wi git url: ssh:/fliwang@git eclipse.org/gitroot/platform/eclipse_platform._ui gt/
D N location: root / eclipse.platform.ui
n
JSLint fﬂL
w OUTGOING (0] git url: https://github.com/douglascrockford/JSLint git
location: root / JSLint
No Changes MyClonedFolder fﬁ
git url: git://github_com/kenwalker/webapp_example git !
¥ INCOMING (0)] location: root / MyClonedFolder
M i
No Changes| New repo 2 m
(no remote)
location: root / new repo 2 <
w HISTORY
Clone Repository  Init Repository N

6) Verify the history of the ripository.



REPOSITORY:EMyCIonechIder VJ REFERENCE: master => origin/master v

Active Branch (master) Y ¥ Sync c

Working Directory Changes 1
Nothing to commit.

v OUTGOING (0) Push v
No Changes

v INCOMING (0) 3 L A Fetchv
No Changes

w HISTORY

' Updated doc

kenwalker on 6/28/2012, 5:15:17 FM
commitied by kenwalker <ken_walker@ca.ibm.com=>

commit: 4a3f2417d332f60e733da2ccbd6f82ablab2fSeb

branches: master| origin/master

less ...
Updated documentation

‘ kenwalker on 6/26/2012, 5:11:35 PM
more ...

GVT0210 Changing a file

1) Press Ctrl+Shift+F (Cmd+Shift+F MacOS) and type a€eeindex.htmla€ in the dialog that appears. Click on the index.html file link.

Find File Named

Type the name of a file to open (7 = any character, * = any string):

index htrml|
ndex.html

2) This should open index.html in the editor. You want to make the following change just so that other Orion screens can be verified. Replace the a€ceHelloWorlda€ text
with a string in the language of your choice. (e.g. in the screenshot below it has been replaced with 4€ceMAKE THIS CHANGEA€).

= Orion Content / MyClonedFolder ! index.html * ;
File Edit View Tools Line 5:Col 10 &
Orion Content {orion.eclipse.org) = <!DOCTYPE html>
<html lang="en">
» BasicProject <head>
<meta Shaciais 2
v MyClonedFolder <titlgs FREVEREETITES lWeb Application</title>
</head>
» .git <body>
<hl:Welcome to your Web Application</hl:
» webapp <p>
If you are seeing this after launching your application you have created
index.html <;p§ E BY PP ¥ y
</body>
[ README.md </html>

» Testing

3) Press Ctrl+S to save the change you made. Click on the repository icon again in the vertical side-menu.
4) On the right hand side of the repository page expand the index.html file's row by clicking on the triangle to the left of the file name.

5) You should now see an area showing the code that was modified in step 2. Verify that the original line containing the &€ccHelloWorlda€ string is highlighted in red and



that there's a new line below it highlighted in green containing the string that you entered in step 2.

a Working Directory Changes T f
Enter the mmit message
e
v J Amend previous commit ALl
Select All 0 files selected =
index_html
. Bl
= # 0 4+ t

<!DOCTYPE html:>
<html lang="en">

<head>
<meta charset=utf-8>
<title>HelloWorld Web Application</title>

</head>
<bod

hl>Welcome to your Web Application</hl>

h1>MAKE THIS CHANGE Web Application</hl>

<p
If you are seeing this after launching your application you have created your first Web App!

</p>
</body>
</html>

4

GVT0220 Git commit

1) On the right hand side of the repository page, check the check box on the left side of the 4€ceindex.htmla€ file name. 2) Enter a commit message in the language of

your choice and hit 4€ceSubmita€.

Working Directory Changes

| Commit message in your languge| I

J Amend previous commit

v| Select Al 1 file selected

» [} indexhim

3) You should see another box appearing under the commit message box asking for information about the committer. Enter the required info in the language of your

choice and press commit again.



Working Directory Changes

Commit message in your languge

J Amend previous commit
J Add Change-ID to message

J Add Signed-off-by to message

Author:

Nam@ author Email: \author@tvt.com j

Committer:

Name@author Email: |auth0r@tvt.c0m j ) Save
v| Select Al 1 file selected

vl » D index_html

4) The commit should now appear on the top of the left hand side od the page. Click on "more" button to see more information about it. Verify that all the information
you entered in steps 2 and 3 is being displayed correctly.

REPOSITORY: MyClonedFolder ¥ REFERENCE: master => origin/master v

Active Branch (master) Y ¥ m We

-

Working Directory Changes -
Nothing to commit.

v OUTGOING (1) Push v

{"Commit message in your languge ‘\

tvt author on 4/11/2015, 6:13:49 PM
committed by tvt author <author@fwt.com=

commit: 42fcf4c378421bdcBecbbdd993358e2848eeadabs

branches: |master

. Y,
w INCOMING (0) 3 Y & Fetchv
No Changes

5) Select the commit and press the a€ceReverta€ button on the right hand side. This will revert the commit back to your work space.



REPOSITORY: MyClonedFolder ¥ REFERENCE: master => origin/master v

Active Branch (master) Revert this commit, keeping all changed files and not making any changes to the working Q a
directory.

Working Directory Changes llie Changed E
Nothing to commit. v D index_html
¥ OUTGOING (1) Push v = S o E V¢
<!DOCTYPE html> o
Commit message in your languge <html lang="en">
<head>
tvt author on 4/11/2015, 6:13:49 PM <meta charset=utf-8>
committed by tvt author <author@tvt.com= <title>HellolWorld Web Application</
</head>
commit: 42fcf4c378421bdcBebbdd993358e2848eeadabd <body>
<hl>Welcome to your Web Application I

Part 3 Search

GVTO00300 Search in the language of your choice

1) In the editor page, right click on the "MyClonedFolder" created in part 2 and select "search in folder...".

File  Edit \View Tools

Orion Content (orion.eclipse.org) «
» eclipse platform.ui

» JSLint

» languagePack

v MyClonedFolder

- New .
e Cut Cirl+X
v webapp Copy CtrieC

helloworld-ine 251 Ctri+V
Delete Del
helloworldjs | moname -

k& helloworld.pnj Compare with...

[ helloworld.we Open with g
Open related >

index_html Import .
[y README . md Export »

ﬂSearch in folder.__. J

] } Show problems...
» org.eclipse.orion.senee:

» new repo 2

2) A slide out pane appears on hte left hand side of the page. Type a search term and click on searc hbutton.
File  Edit View Tools

X
812

Switch to Replace Mode
Case sensitive Regular expression

File name patterns (comma-separated)

Wy ClonedFolder




3) Check the search result on our search term.

» Edit Search X
Files 1-1 of 1 matching "function™
(R 2

v D My ClonedFolder/webapp/helloworld.js (5 matches)

14: window.onload ){
16: requestonsuccess = ){

33: installApp.addEventListener("click” |funt:'ti onl) {

37 installing.onsuccess :Ifunctioie) {

GVT00310 Global replace

1) Click on "edit seach" link in the search result pane.

2) Click on "Switch to replace mode" link and put a replace term in the replace box. Click on "replace".

function v E
IEwitch to Replace MOdﬂ

Case sensitive | Regular expression [

File name patterns (comma-separated)

Scope
Wy ClonedFolder

function v

IIfunctionaﬂ ] Replace...

Switch to Search Mode

Case sensitive | Regular expression [

File name patterns (comma-separated)

v

3) This should show you a preview of the Original and Replaced file as can be seen in the following screenshot. Check that the search and replace terms are properly
highlighted and that the replacement makes sense.



File  Edit \View Tools

Preview: helloworld.js

. x f’l:r.-ﬂlﬂl:r.-ﬂk’l:r.-t*’l:r.-t*’l:v.-c*!l:v.-t*ﬂ:'.-t**:r.-ﬂk’l:r.-ﬂlﬂl:v.-ﬂk!l:'.-t**
* Edit Search . o
|Replace "function” with "functional” for files 1-1 of 1 | * Eopyright (c) 2012 IBM Corporation and othe
Replace Selected % * All rights reserved. This program and the a
= IE‘ IE‘ ‘ t * available under the terms of the Eclipse Pu
., . . * (http://www.eclipse.org/legal/epl-v1@.html)
v v D My ClonedFolderwebapp/helloworld.js (5 matches) * license v1.0 (http://www.eclipse.org/org/de
v| 14:window.onload = function() { *
* Contributors:
16:request.onsuccess = function(e) { * IBM Corporation - initial API and imple
v 30' = b 0 0 o b e oo b e 0 o b o e o b e s o o e sk o o ol ok o o o ok ok b o ok o b o o R R K
() { /*global window */
v  3%installApp.addEventListener("click", function() { /*jslint browsep-troe
. _ . window.onload o funetion() {
v|  3T:installing.onsuccess = funetion(e) { window.onload = functional()]{

var reqguest i =
request.onsuccess § function(e)|{
request.onsuccess § functional(f) {

var installApp = oocument.getElementBy

drnc+alTAnn Aicahlad — £4aTlecAx

= wWind

4) Click on the a€ceReplace selecteda€ button that is above the search results section.

5) Use Ctrl+Shift+F (Cmd+Shift+F MacOS) to open the the file you just modified in the editor and check that the text was replaced successfully
Part 4 Orion Console

GVTO00400 Is, change directory, auto-complete, edit

1) Click on the shell icon in the vertical side-menu

2) The Shell page should open and the cursor should be in the input area at the bottom of the page

= BasicProject

For a list of available commands type 'help’.

Initial directory: /Qrien Content/BasicProject/

3) Type in a€celsa€ and press Enter

4) If you have just completed the 4€ceGlobal replacea€ test case, you should see the name of the project that contains the renamed file you modified as well as the list of
files and folders it contains.

5) Change directories into a folder that you renamed by typing 4€cecd <renamed folder name>4a€ and press Enter. The cd command has auto complete so you should be
able to match part of the folder name and press tab to auto complete and then press Enter



For a list of available commands type 'help’.

Initial directory: /Orion Content/BasicProject/
» |5
renamedNewFolder

project.json
renamedNewFile.txt

The name of the directory
renamedMNewFolder

» cd renamedN|

6) Go back to the parent directory by typing &€cecd ..4€ and pressing Enter

7) Test that launching the editor on a file with a name in a different language works properly by typing in 4€ceedit <the file you renamed>a€ and press Enter. The edit
command has auto-complete so you should be able to match part of the file name and press tab to auto complete and then press enter

8) The file should open properly in the editor using that command.

For a list of available commands type 'help'.

Initial directory: /Orion Content/BasicProject/
» g5

renamedtewFalder

project.json

renamedNewFile tit

= cd renamedMewFolder
Changed to: /Qrien Content/BasicProject/renamedNewFolder/

=cd .
Chan at/BasicProject/

The name of the file
renamedMewFiletd

» edit renamedNewFi|

Part 5 Sites

GVT00500 Creating, starting, stopping and deleting site

1) Click on the Sites icon in the vertical side-menu.
2) When the a€ceSitesa€ page appears, press the a€eCreatea€ button.

3) Type in a name for your site in the language of your choice and hit Submit.

= Sites

You have no sites. Click Create tocreate a site.

4) In the 4€ceMappingsa€ section of the resulting page, press the 4€eAdda€ dropdown button and choose the folder you cloned the webapp_example project into



Start Convert to Self-Hosting

Name: guitesting

Hostname hint: guitesting Optional: used to determine the URL where a started site can be accessed.

Status: Stopped

.
w Mappings Add
IBasicProject
| niycionedrolder
fMesting

Path Mount at (server path) Actions

Choose folder...
URL

——

5) Press the a€ceStarta€ button in the upper left portion of the page. The d4€ceStatus:a€ message should say that your site has been started and should contain a link to it.

Stop Convert to Self-Hosting

Mame: gvitesting
Hostname hint: guitesting Optional: used to determine the URL where & started site can be accessed.
Status: Started at hitp://gvttesting.orion.eclipse.org:8080

Changes you make here won't affect the running site.

w Mappings Add

Path Mount at {server path) Actions

™ lgttester1-OrionContentMyClonedFolder ! x t +

6) Press the a€ceStopa€ button to stop the site from running. You want to click on the 4€ceSitesa€ portion of the Breadcrumb at the top of the page to return to the list of

all Sites.
g\me sting

Start Convert to Self-Hosting

Name: guitesting

7) Ensure that the site name you selected is being properly displayed in that page.

8) Press the a&€ceDeletea€ to the right of the site you just created and confirm that you DO want to delete it.



orion.eclipse.org/sites/sites.html

Apps B Orion H Open Source Sit.. . . b B BlueMix
The page at https://orion.eclipse.org says: *

Are you sure you want to delete the site
configuration 'gvttesting’?

| OK Cancel
gvttesting

Stopped

Create

e the site configuration Delete

Part 6 Global functionality

GVT00600 Keyboard shortcuts filtering

1) Open any editable file in the editor

2) Press the a€ceoptionsa€ button in the top right and click on Keyboard Shortcuts in the dropdown menu that appears.

-
Help I
Reporta Bug
I Keyboard Shortcuts
Getting Started
Settings
Sign Out

3) In the keyboard shortcuts popup verify that you can filter appropriately. Then press escape to close the dialog.



it
| Editor

! Add Block Comment

Collapse

Collapse All

Delete Lines

Delete Next Character
Delete Next Word

Delete Previous Character
Delete Previo

Delete Previous Word
Delete Previous Word
Document End
Document Start

Expand

Expand All

Find Next Occurrence
Find Previo CUITENCE
Find...

Goto Line...

Inrramantal Find

Part 7 Cleanup and signout

1) Click on the Editor (pencil) icon in the vertical side-menu

Ctrl+Shift+?
Ctrl+Alt+C
Ctrl+Shift=Alt+C
Ctrl+SPACE
Ctrl+Alt+SPACE
Crl+Alt+]
Crl+Alt+1
Ctrl+D

DEL

Ctri+DEL
BKSPC
Shift+BKSPC
Ctrl+BKSPC
Ctrl+Shift+BKSPC
Ctri+END
Ctri+HOME
Ctrl+Alt+E
Ctrl+Shift+Alt+E
Cirl+K
Ctrl+Shift+K
Ctri+F

Ctri+L

Marla

2) Hold the Ctrl (Cmd MacOS) key and select both top-level folders you created in the navigator using your mouse

3) Delete both of them by triggering the context menu on one of them, clicking on Delete and confirming that you DO want to delete them.

File  Edit View

» BasicProject
» MyClonedFolder

p Testing

4) Choose the a€eOptionsa€ button in the top right and select the menu item a€ceSign Outa€

-
Help
Report a Bug
Keyboard Shortcuts
Getting Started
Settings
| sion out

If all the steps above were followed in sequence then the testing account should be left in the same state as when you started. Page

Orion Content (orion.eclipse.org)

Cut
Copy
I Delete

Compare with each other

Orion Content

 Projects
Testing

RenamedBasicProject

 Orion Content
™1 BasicProject
™1 MyClonedFaolder

™ Testing

This is a GVT test project

http:/fwww.google.com
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